WARNING! Protect your site! – ImageMagick Is On Fire — CVE-2016–3714 ( multiple vulnerabilities in ImageMagick )

QuestionsCategory: PDF Light ViewerWARNING! Protect your site! – ImageMagick Is On Fire — CVE-2016–3714 ( multiple vulnerabilities in ImageMagick )
supportsupport asked 2 years ago

There are multiple vulnerabilities in ImageMagick, a package commonly used by web services to process images. One of the vulnerabilities can lead to remote code execution (RCE) if you process user submitted images. The exploit for this vulnerability is being used in the wild.

A number of image processing plugins depend on the ImageMagick library, including, but not limited to, PHP’s imagick, Ruby’s rmagick and paperclip, and nodejs’s imagemagick.

The PDF Light Viewer plugin is also using ImageMagick. So if you’re using the plugin, then you’re using the ImageMagick.

So you (your server administrator or your hosting provider) should take steps to protect your site.

Please follow this link to learn more about protection process – https://imagetragick.com/