PHP 7 Compatibility

QuestionsCategory: PDF Light ViewerPHP 7 Compatibility
Kelona asked 3 months ago

Hi, I am running PDF Viewer Lite on my wordpress site and want to update to PHP7. When I ran a scan to check for compatibility issues, I received the following warning and errors. Will these affect the functionality of the plugin? If yes, when will these be repaired?
 
Thanks in advance.
 
FILE: **removed for security**/plugins/pdf-light-viewer/controllers/PdfController.php
————————————————————————————————————
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
————————————————————————————————————
739 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4

1 Answers
supportsupport answered 2 months ago

Hello Kelona,
The plugin is tested and worked fine with php7 (in our local environment we have 7.1.17 currently).